Knewton.com Issue
Incident Report for Knewton.com
Resolved
On February 2nd, the Knewton Technology Team resolved an issue affecting Knewton.com. It began at 00:52 UTC and was resolved as of 3:23 UTC. During this time, users may have had difficulty accessing or using Knewton. This issue has now been resolved.
Posted about 2 months ago. Feb 02, 2017 - 03:32 UTC
Investigating
On February 1st, the Knewton Technology Team detected an issue affecting users accessing and using Knewton. We're currently looking into the issue. We will provide an update on this page as soon as we have more information. Thanks for your patience.
Posted about 2 months ago. Feb 02, 2017 - 01:44 UTC