Issue with Alta
Incident Report for Knewton alta
Resolved
On March 24th, 2020, the Knewton Technology Team resolved an issue affecting Alta. We’re sorry for any inconvenience this caused.
Posted Mar 24, 2020 - 22:56 UTC
Investigating
Knewton has received reports of intermittent issues with Alta. We're currently looking into the issue. We will provide an update on this page as soon as we have more information. Thanks for your patience.
Posted Mar 24, 2020 - 22:43 UTC
This incident affected: Knewton alta.