Investigating Knewton Issue
Incident Report for Knewton.com
Resolved
On May 2nd 2017, the Knewton Technology Team resolved an issue affecting Knewton. It began at 15:58 UTC and was resolved as of 16:50 UTC. During this time, users may have had difficulty accessing Knewton. This issue has now been resolved.
Posted over 1 year ago. May 02, 2017 - 16:59 UTC
Investigating
On May 2nd 2017, the Knewton Technology Team detected an issue affecting Knewton.com. It began at 15:58 UTC, and we're currently looking into the issue. We will provide an update on this page as soon as we have more information. Thanks for your patience.
Posted over 1 year ago. May 02, 2017 - 16:28 UTC