Knewton.com Issue
Incident Report for Knewton.com
Resolved
On September 23rd, 2016, the Knewton Technology Team resolved an issue affecting Knewton.com. It began at 20:23 UTC and was resolved as of 20:42 UTC. During this time, users could not access or log into Knewton.com. This issue has now been resolved.
Posted 7 months ago. Sep 23, 2016 - 20:49 UTC
Investigating
On September 23rd, 2016, the Knewton Technology Team detected an issue affecting access to Knewton.com. We're currently looking into the issue. We will provide an update on this page as soon as we have more information. Thanks for your patience.
Posted 7 months ago. Sep 23, 2016 - 20:36 UTC