Knewton.com Issue
Incident Report for Knewton.com
Resolved
On February 28th, the Knewton Technology Team resolved an issue affecting Knewton. It began at 18:07 UTC and was resolved as of 21:12 UTC. During this time, users may have had difficulty accessing Knewton. This issue has now been resolved. We sincerely apologize for any inconvenience this caused.
Posted 3 months ago. Feb 28, 2017 - 22:23 UTC
Investigating
On February 28, 2017, the Knewton Technology Team detected an issue affecting Knewton.com. It began at 18:07 UTC, and we're currently looking into the issue. We will provide an update on this page as soon as we have more information. Thanks for your patience.
Posted 3 months ago. Feb 28, 2017 - 19:05 UTC