Issues With Login
Incident Report for Knewton.com
Resolved
On July 25, 2018, the Knewton Technology Team resolved an issue affecting Knewton alta users where they are unable to login to the website. It occurred at 16:45 UTC and was resolved at 18:37 UTC .
Posted 5 months ago. Jul 25, 2018 - 18:55 UTC
Investigating
The Knewton Technology Team detected an issue affecting Knewton alta users where they are unable to login to the website. It occurred at 16:45 UTC. We will provide you with a further update as we continue to monitor the issue.
Posted 5 months ago. Jul 25, 2018 - 18:16 UTC
This incident affected: Knewton.com.