Investigating Knewton Issue
Incident Report for Knewton.com
Resolved
On 30th October 2017, the Knewton Technology Team resolved an issue affecting Knewton. It began at 12:50 UTC and was resolved as of 14:25 UTC. Operations returned to normal at 14:25 UTC
Posted about 1 year ago. Oct 30, 2017 - 15:06 UTC
Investigating
On October 30th 2017, the Knewton Technology Team detected an issue affecting Knewton. It began at 12:50 UTC, and we're currently looking into the issue. We will provide an update on this page as soon as we have more information. Thanks for your patience.
Posted about 1 year ago. Oct 30, 2017 - 13:56 UTC