Issue with Alta Assessments
Incident Report for Knewton alta
Resolved
On 3/24/2022), the Knewton Technology Team resolved an issue affecting Alta. It began at 6:24 PM EDT and was resolved as of 7:08 PM EDT. We’re sorry for any inconvenience this caused.
Posted Mar 24, 2022 - 23:12 UTC
Investigating
We are currently investigating a possible issue with Assessments for Alta. For future updates, please visit http://status.knewton.com, as they become available.
Posted Mar 24, 2022 - 22:48 UTC
This incident affected: Knewton alta.