Knewton.com Issue
Incident Report for Knewton.com
Resolved
On October 21, 2016, the Knewton Technology Team resolved an issue affecting Knewton.com. It began at 16:20 UTC and was resolved as of 20:17 UTC. During this time, users may have been unable to access the Knewton.com website. As of 20:17 UTC access to the website was fully restored. Thanks for your patience with this.
Posted 11 months ago. Oct 21, 2016 - 21:17 UTC
Investigating
On October 21st, 2016, the Knewton Technology Team detected an issue affecting access to Knewton.com. It began at 16:20 UTC, and we're currently looking into the issue. We will provide an update on this page as soon as we have more information. Thanks for your patience.
Posted 11 months ago. Oct 21, 2016 - 17:32 UTC