Investigating Knewton Issue
Incident Report for Knewton.com
Resolved
On July 4th, 2017, the Knewton Technology Team resolved an issue affecting Knewton. It began at 01:58 UTC and was resolved as of 02:31 UTC. During this time, users may have had difficulty accessing Knewton. This issue has now been resolved.
Posted over 1 year ago. Jul 04, 2017 - 02:42 UTC
Investigating
On July 3rd, 2017, the Knewton Technology Team detected an issue affecting Knewton.com. We are currently looking into the issue. We will provide an update on this page as soon as we have more information. Thanks for your patience.
Posted over 1 year ago. Jul 04, 2017 - 02:15 UTC