Issue in Knewton.com
Incident Report for Knewton.com

On July 29th, 2016, the Knewton Technology Team resolved an issue affecting Knewton.com. It began at 12:00 UTC and was resolved as of 12:45 UTC. During this time, users may have had difficulty logging in or accessing Knewton.com. Operations returned to normal at 12:45 UTC.

Posted 12 months ago. Jul 29, 2016 - 18:06 UTC

Resolved
On July 29th, 2016, the Knewton Technology Team resolved an issue affecting Knewton.com. It began at 12:00 UTC and was resolved as of 12:45 UTC. During this time, users may have had difficulty logging in or accessing Knewton.com. Operations returned to normal at 12:45 UTC.
Posted 12 months ago. Jul 29, 2016 - 13:30 UTC
Investigating
On July 29th, 2016, the Knewton Technology Team detected an issue affecting Knewton.com. It began at 12:00 UTC, and we're currently looking into the issue. We will provide an update on this page as soon as we have more information. Thanks for your patience.
Posted 12 months ago. Jul 29, 2016 - 12:26 UTC