Investigating Knewton Issue
Incident Report for Knewton.com
Resolved
On May 4, 2017, the Knewton Technology Team resolved an issue affecting Knewton. It began at 19:43 UTC and was resolved as of 20:04 UTC. During this time, users may have had difficulty accessing and/or using Knewton. This issue has now been resolved.
Posted over 1 year ago. May 04, 2017 - 20:20 UTC
Investigating
On May 4, 2017, the Knewton Technology Team detected an issue affecting Knewton.com. We are currently looking into the issue. We will provide an update on this page as soon as we have more information. Thanks for your patience.
Posted over 1 year ago. May 04, 2017 - 20:02 UTC